Cryptocurrency sends/receives are being impacted

Incident Report for Rain

Resolved

This incident has been resolved.
Posted May 26, 2021 - 13:43 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 26, 2021 - 12:41 UTC
This incident affected: API.