Degraded performance
Incident Report for Rain
Resolved
This incident has been resolved.
Posted Apr 10, 2021 - 18:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 10, 2021 - 18:02 UTC
Investigating
We are currently investigating this issue.
Posted Apr 10, 2021 - 17:34 UTC
This incident affected: Website, API, and Mobile.