rain.com website is inaccessible
Incident Report for Rain
Resolved
website is accessible now.
Posted Nov 08, 2022 - 10:16 UTC
Update
We are continuing to investigate this issue.
Posted Nov 08, 2022 - 09:42 UTC
Investigating
We are currently investigating this issue.
Posted Nov 08, 2022 - 09:40 UTC
This incident affected: Website.