Issue fetching ETH pricing
Incident Report for Rain
Resolved
This incident has been resolved.
Posted Jul 26, 2021 - 19:08 UTC
Investigating
We are currently investigating this issue.
Posted Jul 26, 2021 - 16:10 UTC
This incident affected: Website, API, and Mobile.