ETH sends being delayed

Incident Report for Rain

Resolved

Incident resolved
Posted Mar 31, 2021 - 21:38 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 31, 2021 - 14:19 UTC

Identified

We've identified an issue that is causing ETH sends to be delayed.
Posted Mar 31, 2021 - 14:19 UTC
This incident affected: API.