Market Page
Incident Report for Rain
Resolved
This incident has been resolved.
Posted Apr 07, 2022 - 07:14 UTC
Update
We are continuing to investigate this issue.
Posted Apr 06, 2022 - 21:34 UTC
Investigating
We are aware of an ongoing problem where some customers maybe experiencing issues when accessing our Market page.

We apologise for any inconvenience

Our Technical teams are working to restore services as quickly as possible
Posted Apr 06, 2022 - 21:30 UTC
This incident affected: Website and Mobile.