Degraded performance
Incident Report for Rain
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 22:32 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 06, 2021 - 20:36 UTC
This incident affected: Website, API, and Mobile.