Service degradation
Incident Report for Rain
Resolved
We have resolved the incident.
Posted Apr 06, 2021 - 14:57 UTC
Investigating
We are currently investigating this issue.
Posted Apr 06, 2021 - 12:27 UTC
This incident affected: Website, API, and Mobile.