Degraded Performance

Incident Report for Rain

Resolved

This incident has been resolved.
Posted Jul 26, 2021 - 12:54 UTC

Investigating

We are currently investigating an issue on our website which is resulting in degraded performance. Our team is actively working on this and will be resolved shortly. Please use the Mobile App in the meantime
Posted Jul 26, 2021 - 12:08 UTC
This incident affected: Website.