New and current application signups

Incident Report for Rain

Resolved

This incident has been resolved.
Posted Jan 27, 2022 - 19:00 UTC

Investigating

We are currently experiencing problems with new user and current application signups via our website.
The issue is being attended too.
More updates to follow
Posted Jan 27, 2022 - 17:11 UTC
This incident affected: Website.