Card buys degraded

Incident Report for Rain

Resolved

This incident has been resolved.
Posted Jul 27, 2021 - 07:49 UTC

Investigating

We are currently investigating this issue.
Posted Jul 27, 2021 - 01:24 UTC
This incident affected: Website, API, and Mobile.